eclipse - Faire fonctionner Subclipse dans Aptana avec la dernière version de Subversion

Translate

La version deSous-clipse (1.2.4)actuellement disponible via le système automatique d'AptanaGestionnaire de pluginsne fonctionne pas avec la dernière version de Subversion.

Je vois cependant sur le site Web de Subclipse qu'ils ont la version 1.4.2 pour Eclipse. Alors j'ai ajouté unnouveau site de mise à jour à distanceà mon gestionnaire de mise à jour. Quand j'ai essayé de l'installer, il m'a dit que j'avais besoinMylyn 3.0.0. Donc, après de nombreuses recherches, j'ai trouvé Mylyn 3.0.0 et ajoutéun autre nouveau site de mise à jour à distanceà mon gestionnaire de mise à jour. Puis quand j'ai essayé d'installer ça, ça m'a dit que j'avais besoinorg.eclipse.ui 3.3.0ou équivalent.

En regardant les détails de configuration pour Aptana, il semble qu'il soit construit contre eclipse 3.2.2.

Est-ce que quelqu'un sait s'il existe un moyen de mettre à niveau la version d'Eclipse Aptana qui est construite avec la version 3.3.0? Ou s'il existe un autre moyen de faire fonctionner Subclipse avec la toute dernière version de Subversion?

Je sais que ce n'est pas nécessairement une question de "programmation", mais j'espère que ça va car c'est très pertinent pour l'expérience de programmation.

This question and all comments follow the "Attribution Required."

Toutes les réponses

Translate

Subclipse ne nécessite pas Mylyn, mais le site de mise à jour inclut un plugin qui intègre Mylyn et Subclipse. Ceci est destiné aux personnes qui utilisent Mylyn. Dans votre cas, vous voudrez simplement désélectionner Mylyn dans la boîte de dialogue de mise à jour.

Subclipse nécessite également Subversion 1.5 et la version correspondante des bibliothèques natives JavaHL. J'ai écrit le début d'une FAQ pour aider les gens à comprendre JavaHL et comment l'obtenir. Voir:http://desktop-eclipse.open.collab.net/wiki/JavaHL

La source
Marjorie Lee
Translate

J'ai eu des problèmes avec JavaHL dans Eclipse Ganymede, alors que cela fonctionnait bien dans Eclipse Europa. Je ne sais pas en quoi Aptana est différent, mais essayez de mettre à niveau JavaHL ou de passer à l'implémentation pure-java SVNKit dans la configuration Subclipse.

La source
Translate

si vous n'utilisez pas mylyn, décochez simplement cette dépendance. Je ne suis pas vraiment familier avec Aptana, mais dans eclipse, vous pouvez développer ce qui est installé et décocher tout ce dont vous n'avez pas besoin.

La source
Translate

J'ai utilisé l'url de mise à jour et j'ai installé l'adaptateur JavaHL, le projet Subclipse lui-mêmeetl'adaptateur SVNKit BETA.

Après cela, cela a bien fonctionné pour moi, c'est pour la plate-forme Linux, j'espère que cela fonctionne pour vous.

La source