eclipse -让Subclipse在Aptana中使用Subversion的最新版本

Translate

版本子剪辑(1.2.4)目前可通过Aptana的自动插件管理器不适用于最新版本的Subversion。

我在Subclipse网站上看到,但是他们有1.4.2用于Eclipse。所以我加了一个新的远程更新站点给我的更新经理。当我尝试安装它时,它告诉我我需要麦琳3.0.0。因此,经过大量搜索,我发现了Mylyn 3.0.0并添加了另一个新的远程更新站点给我的更新经理。然后当我尝试安装它时,它告诉我我需要org.eclipse.ui 3.3.0或同等学历。

查看Aptana的配置详细信息,看起来它是针对Eclipse 3.2.2构建的。

有谁知道是否有办法将针对其构建的Eclipse Aptana版本升级到3.3.0?或者,如果还有其他方法可以让Subclipse与最新版本的Subversion一起使用?

我知道这不一定是一个“编程”问题,但是我希望它可以,因为它与编程经验高度相关。

This question and all comments follow the "Attribution Required."

所有的回答

Translate

Subclipse不需要Mylyn,但是更新站点包括一个集成了Mylyn和Subclipse的插件。这是供使用Mylyn的人使用的。对于您的情况,您只想在更新对话框中取消选择Mylyn。

Subclipse还需要Subversion 1.5和相应版本的JavaHL本机库。我已经写了一个常见问题解答的开头,以帮助人们了解JavaHL以及如何获得它。看到:http://desktop-eclipse.open.collab.net/wiki/JavaHL

来源
Marjorie Lee
Translate

当它在Eclipse Europa上运行良好时,我在Eclipse Ganymede中遇到了JavaHL问题。我不确定Aptana会有什么不同,但是请尝试升级JavaHL或在Subclipse配置中切换到纯Java SVNKit实现。

来源
Translate

如果您不打算使用mylyn,请取消选中该依赖项。我对Aptana并不是很熟悉,但是在Eclipse中,您可以扩展正在安装的内容并取消选中不需要的内容。

来源
Translate

我使用了更新网址,并安装了JavaHL适配器(Subclipse项目本身)SVNKit适配器测试版。

在此之后,它对我来说效果很好,这是适用于linux平台,希望对您有用。

来源